mlfk.net
当前位置:首页 >> jAvA 中mysql驱动的版本之间的差异 >>

jAvA 中mysql驱动的版本之间的差异

这跟Mysql的版本和JDK的版本升级是有关系的,Mysql从3.x 4.x 到5.x都不同版本的mysql-connector/J,在Mysql官网可以看到每个版本的mysql-connector/J的ChangeLog,现有的版本号是: 5.1.x、5.0.x、3.1.x、3.0.x、2.0.x和1.2.x,每一个版本的初始...

基本相同,向下兼容,版本越高越好,对低版本都兼容。

private String dbid = "jdbc:mysql://localhost:3306/数据库名称"; private String drivername = "com.mysql.jdbc.Driver"; private String username = "root"; private String password = "数据库密码"; Class.forName(drivername); con = Dri...

mysql-jdbc这jar包用的很少,这个包是一开始java定义的规范,连接过程要经过操作系统odbc桥接,后来发现这种方式效率不高,就改成mysql-connector这种直接连接数据库的方式。所以一般使用mysql-connector这个jar包。

驱动jar包升级,无非是因为远来的jar本来就有些缺陷要修改,或者要做必要的优化。还有就是数据库也不断升级,那驱动包自然要升级,不然有可能出错。 理论上是越高级 越好的,不过具体要看数据库版本,有些版本太低了,用最新jar未必会最优

public class MyConnect { private static Connection con = null; public static Connection getConnection(){ try { /** MyQL数据库驱动路径*/ Class.forName("com.mysql.jdbc.Driver"); try { con = DriverManager.getConnection("jdbc:mysql...

mysql-connector-java-5.0.8-bin.jar对应mysql5.0以上的版本 mysql-connector-java-commercial-5.1.28-bin 就是 Connector J 5.1.28 里面的jar包 驱动向下兼容的,mysql-connector-java-commercial-5.1.28-bin 的驱动,可以兼容低版本的mysql数...

我传给你,我用是jdk1.7.0 mysql5.0 tomcat 6.0 myeclipse 6.0 百度hi随时在,需要me 我 连接mysql只需要一个jar包就可以了!!!

这个版本就可以使用,mysql-connector-java-5-bin.jar 你可以在http://download.csdn.net/detail/zzzzzqf/8269609进行下载

你报的问题是没有找到类,而不是类版本错误。 你确定你的mysql-connector-java 已经加入到你的构建路径中了么?

网站首页 | 网站地图
All rights reserved Powered by www.mlfk.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com