mlfk.net
当前位置:首页 >> linux下安装rpm遇到的包依赖问题 >>

linux下安装rpm遇到的包依赖问题

1.加上 --nodeps,意思不考虑依赖 2.更狠的--force,强制安装 你可以在这两个之前试试--aid自己解决依赖

你的命令没有问题。 rpm-5.1.6.tar.gz不是rpm包,是一个gz的压缩包,用tar -xzvf rpm-5.1.6.tar.gz是可以解压成功的。 如果你要装rpm包,应该是 rpm -ivh 包名,或者你那个rpm-5.1.6.tar.gz原本是rpm包,后来被重命名了,你用rpm -ivh rpm-5.1.6....

哪有自己依赖自己的rpm包的呢,截图上面的提示信息的意思是needed by,是某某rpm包“被......依赖”的意思,所以“needed by”前面的名字才是安装时依赖的软件包,这个软件包依赖的应该是libcom_err-devel和pkgconfig(com_err)这两个软件。

表示nsmbd这个包要依靠或调用libc.so.6,libpam.so.0等等这些的函数库或其他类似数据。所以要解决就必须安装这4个东西。 如果你是RH的,就#YUM INSTALL GLIBC—2。4。。。括号里面的那个名称 依次装完就可以装nsmbd。 如果ubuntu或dbian 就#apt-...

下载安装埃。。不会源代码安装就用yum install去安装 很方便的

方法1: rpm -ivh elfutils-libelf-devel-0.137-3.el5.x86_64.rmp elfutils-libelf-devel-static-0.137-3.el5.x86_64.rpm 如果还不能,请加--nodeps,如果还不能装,请加--force 方法2: yum install elfutils-libelf-devel*

你的命令没有问题。 rpm-5.1.6.tar.gz不是rpm包,是一个gz的压缩包,用tar -xzvf rpm-5.1.6.tar.gz是可以解压成功的。 如果你要装rpm包,应该是 rpm -ivh 包名,或者你那个rpm-5.1.6.tar.gz原本是rpm包,后来被重命名了,你用rpm -ivh rpm-5.1.6....

原因:fpc-src-2.4.2-0.i686.rpm所依赖的包没有安装上。 最简单的办法: 安装yum 然后用yum install -y fpc-src //yum 安装可以解决rpm包依赖. 比较笨的方法: 如果你有你安装的linux系统的ISO或安装盘解压后从server(red hat 和centos两个系统...

--import是导入密钥,这密钥是红帽公司提供的。 rpm --import /etc/pki/rpm-gpg/RPM-GPG-KEY-redhat-* 或许还可以用于导入别的东西。 -K用于验证所给的包是否为红帽官方提供,当是官评剧提供时,会有“OK”字样。 rpm -K kernel-PAE-2.6.18-194.el...

glibc = 2.5-42 依赖这个版本 你安装的却是 glibc-headers-2.5-24 42和24不同。。

网站首页 | 网站地图
All rights reserved Powered by www.mlfk.net
copyright ©right 2010-2021。
内容来自网络,如有侵犯请联系客服。zhit325@qq.com